Warning message: "Have you reported all of your in...
Sign Up

Why sign in to the Community?

  • Submit a question
  • Check your notifications
or and start working on your taxes
cancel
Showing results for 
Search instead for 
Did you mean: 
RoamingRanger
Returning Member

Warning message: "Have you reported all of your income?"

Full message:

Have you reported all of your income?

[Name] appears to have entered earnings here that belong in other areas of TurboTax. Foreign business income or partnership income should also be entered in the Business Income or K-1 sections of TurboTax. Entries made here are used only to determine how much income from those sources is potentially eligible for exclusion.

Before completing the interview to exclude foreign income, you should visit the Business Income or K-1 interviews in TurboTax to report all worldwide business or partnership income.

 

Context:

My wife is working overseas for a US based ministry (with US address) which we received a W-2 from. I entered the information from the W-2 in the appropriate section and after going through the entire "Foreign Income Exclusion" Interview section on TurboTax I am prompted with the above message. The income isn't from a "foreign business income or partnership", it's from a W-2, so I'm not sure why it's pointing us to the Business Income or K-1 Income section of TurboTax. Any ideas why I'm seeing this or what I entered incorrectly to prompt this?

Also, I'm working remotely for a US company (via W-2) and went through the similar data input steps as I did for her but I didn't see the same warning message after entering my information.

Thanks for any assistance you can provide.

5 Replies
DavidS127
Expert Alumni

Warning message: "Have you reported all of your income?"

Check the entry screens for your wife, paying particular attention to the "Which Form(s) was Foreign Income Reported On?" screen, or any other screen where you entered an income amount for your wife's foreign income.

**Say "Thanks" by clicking the thumb icon in a post
**Mark the post that answers your question by clicking on "Mark as Best Answer"
RoamingRanger
Returning Member

Warning message: "Have you reported all of your income?"

Thanks for the reply @DavidS127 . On that screen, the only checked box is "A regular W-2 from your employer" (which is accurate).

Interestingly, I'm now getting the same message when I review my portion of our income (whereas I wasn't previously). The only information that I changed was the screen titled "Confirm [Name's] Wages Already Entered". This is the screen where you adjust the wages on the W-2 depending on which portion was received overseas compared to income earned in the US. Initially I had miscalculated my income made in the US (which is the portion you subtract from the total income reported on the W-2) and now after entering the correct amount I'm getting the same message. For my wife's W-2, zero has always been entered into the box because 100% of her income was earned overseas. 

DavidS127
Expert Alumni

Warning message: "Have you reported all of your income?"

Check the screens following the "box entry" screen for your W-2.  On the screen "Do any of these uncommon situations apply to this W-2?", make sure the "Worked outside the U.S." box is checked:

 

**Say "Thanks" by clicking the thumb icon in a post
**Mark the post that answers your question by clicking on "Mark as Best Answer"
RoamingRanger
Returning Member

Warning message: "Have you reported all of your income?"

Hi @DavidS127 , Thanks again for your reply. Yes- that box is checked for both of our W-2's which were issued for our work outside the US yet we still are getting the warning message. Any other potential ideas? Thanks again for your help, I really appreciate it!

DavidS127
Expert Alumni

Warning message: "Have you reported all of your income?"

If all the answers in your Foreign Income Exclusion section are accurate, my conclusion is that somehow an errant entry or the sequence of inputs has caused something to be "stuck" in software. 

 

I recommend deleting the any Form 2555-T related forms and any Form 2555-S related forms and the associated Frgn EI Tax Wks from the forms in your return, in the hope that whatever is "stuck" in there will be "flushed" when those forms are repopulated by the software.  Then, go back through the Foreign Income Exclusion section again.  Hopefully that will resolve the issue.

 

If you are using the Download/CD version of TurboTax, you would delete the forms in Forms mode (icon top right in blue bar), and look for the forms in the list of forms in the left column.  When you click on each form, it will open up in the right window and you can delete it with the Delete Form button at the bottom.  Note, too, that errors in these forms will show up as "shaded red", so if you are using Download/CD, you might want to look through them for clues as to what might be causing your error.

 

If you are using an Online version of TurboTax, use the Delete a Form function to delete these forms: 

  1. Open or continue your return in TurboTax.
  2. In the left menu, select the dropdown arrow next to Tax Tools and then underneath that Tools.
  3. In the pop-up window Tool Center, choose Delete a form.
  4. Select Delete next to the form/schedule/worksheet in the list that you need to delete and follow the instructions.

Click here for the full article on deleting a form in TurboTax.

 

The other thing I wanted to ask about was whether on "uncommon situations" screens you had checked anything else, e.g., that the pay was for "religious employment".  There could be a chance that some additional selection on that screen  is causing the software to look for additional entries for income related to religious employment.

**Say "Thanks" by clicking the thumb icon in a post
**Mark the post that answers your question by clicking on "Mark as Best Answer"
Dynamic AdsDynamic Ads
v
Privacy Settings