Sign Up

Why sign in to the Community?

  • Submit a question
  • Check your notifications
or and start working on your taxes
cancel
Showing results for 
Search instead for 
Did you mean: 
albertpliu
New Member

Mortgage Interest not Showing on Schedule A

Thank you very much for reporting this. What a horrible bug! Really frustrating when the worksheet shows you the correct number but it just won't show up in the corresponding Schedule A line. No explanations what so ever. Very bad experience. 

 

Also it keeps crashing when you want to switch form mode before you complete all the review.

arsnls
New Member

Mortgage Interest not Showing on Schedule A

I agree with all of the posts - this is terrible and turbo tax should be ashamed!

 

The fix posted below by VictoriaD75 works - but only people who have a pretty good understanding of taxes would even know to look for the problem. I guarantee there are a lot of returns already completed that are wrong and the taxpayers don't even have a clue.

 

Iv'e been using turbo tax for a long time and have been really pleased.  But this really makes me mad.  

 

Again, turbo tax should be ashamed!

 

Art

 

 

 

post copied from forum -

 

VictoriaD75
Employee Tax Expert
 

There is a workaround for this. 

 

For desktop versions:

  • In Forms view, locate and click on Tax & Int Wks on the left from the forms list
  • On the form, scroll to Mortgage Interest Limited Smart Worksheet
  • Click on NO to the right of the question, Does your mortgage interest need to be limited
**Say "Thanks" by clicking the thumb icon in a post
**Mark the post that answers your question by click
svadrevu
Level 1

Mortgage Interest not Showing on Schedule A

Thank You for suggesting the work around for MAC Desktop version. I am very surprised why Turbo Tax is not able to update this fix via a patch even on 3/30/2019 & I have even called TT Support and they also did not know about this work around.

 

 

For desktop versions: workaround is as below.

  • In Forms view, locate and click on Tax & Int Wks on the left from the forms list
  • On the form, scroll to Mortgage Interest Limited Smart Worksheet
  • Click on NO to the right of the question, Does your mortgage interest need to be limited
moleg
Level 1

Mortgage Interest not Showing on Schedule A

It's 04/14, 10:30pm and this bug still not fixed.

Workaround indeed works, but gosh, it took my some time to google the answer.

 

I have pretty serious doubts about continuing with Intuit for the next tax year ..

dhlee
Level 1

Mortgage Interest not Showing on Schedule A

@arsnls Thanks for pointing back to VictoriaD75 post and copy/pasting her workaround.

Random89
New Member

Mortgage Interest not Showing on Schedule A

I am really really disappointed with Intuit for not fixing this problem. The work around is a nightmare, especially when I will be paying a pretty penny for this software. I have been using Turbo Tax for 8 years. For Intuit not to fix this problem is unacceptable. I went to H&R Block and completed my return without any problem. I feel sorry for the people who filed and not realized the bug. Intuit has lost me as a customer for life. 

 

cjksf
Level 1

Mortgage Interest not Showing on Schedule A

I would love to try that work-around, but I don't see the question "Does your mortgage interest need to be limited" in the Home Mortgage Interest Limitation Smart Worksheet. 

 

I'm using Desktop software on a Mac.

 

What am I missing?

 

Also, I noticed another related issue. If I use the steps suggested by @KrisD15   there's very suspicious behavior. 

 

To the question “Do any of these situations apply to you?”  I select “No” because those situations do not apply in my case to either of the mortgages that I had in 2019. At this point,  my total tax reduces significantly... more than $2,000... but when I click the "Continue." the total tax goes back up.

svadrevu
Level 1

Mortgage Interest not Showing on Schedule A

Not sure why u cannot see that, I just followed below steps. trying to attach screenshot see if it helps.

you may have to Answer Yes & then confirm that ur interest is either from a Re-finance or loan from original home purchase. All of this is assuming that ur Mortgage is for ur primary home & Amt s not > 750K.

  • In Forms view, locate and click on Tax & Int Wks on the left from the forms list
  • On the form, scroll to Mortgage Interest Limited Smart Worksheet
  • Click on NO to the right of the question, Does your mortgage interest need to be limited
 
 
 

TTax-Motg_deduction.png

doreeno007
Level 2

Mortgage Interest not Showing on Schedule A

Thank you all for the fix.  It is completely unacceptable that this hasn't been fixed.

doreeno007
Level 2

Mortgage Interest not Showing on Schedule A

I couldn't let go of this problem. I think that when you are in the step by step area to enter the mortgage information, the box to check Yes or No, Does your mortgage interested need to be limited?  is not there and the answer defaults to Yes. If you go to the Tax Deduction Interest Worksheet to the Mortgage Interest Limited Smartsheet section, you will see the box is checked Yes. Switch it to No and watch your tax liability go down. Note that once checked no, the section is gone in the step by step area.

glennmsmith58
Level 1

Mortgage Interest not Showing on Schedule A

The question is on the Tax & Int Worksheet.  I was frustrated looking for it on the Home Int Worksheet.  It has the very similar heading; Home Mortgage Interest Limitation (instead of Limited) Smart Worksheet, but no question about limiting interest.  Once I found the right worksheet, with Michael's help (at the help line), it worked fine.

 

Also, the workaround instructions to override only works for Windows (right click).  Mac users must click on the field and select Edit->Override.

 

Michael's guess was that my entering 3 1098s caused the total debt to be over the limit, checking that box.  Once checked, it must be manually unchecked.  Good theory.  Not sure if it is true. 

m00ntan
Level 3

Mortgage Interest not Showing on Schedule A

Still a bug.  I can't believe this isn't fixed.

MJPerr
New Member

Mortgage Interest not Showing on Schedule A

Has anyone firgured out how to submit form electronically using this override fix? I’ve figured out how to override the system so that our correct mortgage interest appears as a deduction, but it’s not letting me submit for e-file. I’ve already paid the e-file fee for my state filing and it’s stuck on the last ‘submit’ button. 

hoyasaxa73
Level 2

Mortgage Interest not Showing on Schedule A

This is for tax year 2021.  I refinanced twice.  Turbotax is minimizing my interest deduction because it thinks my outstanding loan balance is the sum total of the two ending balances plus the current loan balance.  Zero is being reported as interest on Schedule A.  Seems there is a bug.

JoannaB2
Expert Alumni

Mortgage Interest not Showing on Schedule A

Yes, you may claim mortgage interest deduction on a loan used to buy/build a home up to $750,000 for married filing joint ($375,000 for married filing separate). The home mortgage loan must be secured by the property to qualify for the deduction. The following are steps to enter deductible home mortgage interest:

  1. Login to Turbo Tax.
  2. Under Federal Taxes, in Deduction and Credit tab, click "I'll choose what I work on".
  3. Under " Your 2020 Deduction and Credit", click update or start next to Mortgage Interest, Refinancing, and Insurance.
  4. Under " Home Loan deduction summary" click edit  and enter the lender's information, one at a time.
  5. Click continue until you get to the screen " Is this loan secured by a property of yours?" 
  6. Click Done.
  7. The next screen is a question " Do any of the situation apply to you?". Your answer here will determine if your loan exceeded the allowed home mortgage loan amount.

See, why is my home mortgage, and click go here for any issues encountered,

Dynamic AdsDynamic Ads
Privacy Settings
v