Sign Up

Why sign in to the Community?

  • Submit a question
  • Check your notifications
or and start working on your taxes
cancel
Showing results for 
Search instead for 
Did you mean: 
tullyncsy
Level 2

I'm a resident of a foreign country

When I go to the foreign tax credit section, it only shows me the small dividend paid to an unrelated different foreign country (this foreign country's tax was on my brokerage form)?
Thank you!!!
1 Best answer

Accepted Solutions
ToddL99
Expert Alumni

I'm a resident of a foreign country

If you are using TurboTax Premier online,  type "foreign tax credit" in the search box, and select "jump to foreign tax credit" from the search results. In each of the following screens, answer the questions carefully and you will be able to report the foreign taxes paid on your foreign stock sales.

 

(I have filled in your selections as far as I went; just select "Continue" to proceed).

 

 

 

View solution in original post

6 Replies
ReneeM7122
Level 8

I'm a resident of a foreign country

If you are a resident of a foreign country and a US citizen, then yes, you should be filing a US tax return.  If you received a form from a brokerage firm with a small dividend paid to a different country, that is normal because it has to do with the fund in your portfolio and not the country that you live in.  Many US companies have investments overseas.

 

 

tullyncsy
Level 2

I'm a resident of a foreign country

Hey Renee and thanks so much for following up!

I'm aware that I need to file a US return. My issue is not paying the same tax twice. So since I am already paying a 25% capital gains tax tot he foreign country, which is higher than the U.S. capital gains rate, I need to indicate somewhere within turbo tax that I made this payment, so it will be credited towards my U.S. tax liability.

But, Turbotax only prompts me to report the credit from the small dividend I paid to a different foreign country that was indicated on my brokerage from. 

But where can I manually enter the much larger 25% tax payment for my capital gains (which is not indicated on my brokerage form)?

ToddL99
Expert Alumni

I'm a resident of a foreign country

Enter the foreign tax you paid in the Foreign Taxes interview of TurboTax, found under Deductions and Credits > Estimates and Other Taxes paid.

 

You may qualify for either a tax credit or a deduction.

 

In most cases, taking the credit works out better than the deduction. We'll help you decide which one's best for you when you go through this section.

 

If you choose to take the credit (most people do), we'll attach Form 1116Foreign Tax Credit if your situation requires it.

 

The following TurboTax FAQs provide instructions on what taxes qualify for the Foreign Tax Credit (or Deduction) and  on how to access the interview.

 

What does or doesn't qualify for the Foreign Tax Credit?

 

Where do I enter the foreign tax credit (Form 1116) or deduction for 2020?

tullyncsy
Level 2

I'm a resident of a foreign country

Hey Todd and thanks for following up!

 

In the foreign taxes interview section it asks me for income earned overseas.

The taxes I'm trying to address are foreign taxes on the Capital gains I earned on my U.S. stock market gains as reported from mu U.S. brokerage account. I don't see a place to enter this data in the foreign taxes interview.

 

The income is currently entered in the capital gains section of turbo tax (over 100 transactions uploaded automatically fro my brokerage tax form(but I don't see anywhere when I can manually indicate the 25% taxes paid to the foreign country based on these U.S. stock market capital gains?

ToddL99
Expert Alumni

I'm a resident of a foreign country

If you are using TurboTax Premier online,  type "foreign tax credit" in the search box, and select "jump to foreign tax credit" from the search results. In each of the following screens, answer the questions carefully and you will be able to report the foreign taxes paid on your foreign stock sales.

 

(I have filled in your selections as far as I went; just select "Continue" to proceed).

 

 

 

View solution in original post

tullyncsy
Level 2

I'm a resident of a foreign country

I think it worked - Thanks so much Todd!

Dynamic AdsDynamic Ads
Privacy Settings
v