Sign Up

Why sign in to the Community?

  • Submit a question
  • Check your notifications
or and start working on your taxes
cancel
Showing results for 
Search instead for 
Did you mean: 
morrillaustin
New Member

I did not work in a foreign country

How do I go back and change that I did not work in a foreign country
7 Replies
LinaJ2020
Expert Alumni

I did not work in a foreign country

 

 

Once you tell the TurboTax program you work in a foreign country,  there is a Form 2555 Foreign Earned Income may have been generated at the back.  To alert the program you did not work in a foreign country, you can simply delete the form.  

 

In TurboTax online, here are the steps:

 

  • Sign in to your account, select Pick up where you left off
  • To your left, Select Tax Tools/drop-down menu
  • Select Tools
  • Under Other helpful links, choose to Delete a form
  • Select Delete next to Form 2555 and Continue with My Return to proceed
**Say "Thanks" by clicking the thumb icon in a post
**Mark the post that answers your question by clicking on "Mark as Best Answer"
fredlorey
Level 1

I did not work in a foreign country

thanks. is this the same answer for turbox from a disc on computer?

I never said I worked for a foreign country and yet it keeps telling me to report earnings tax in a foreign country and it won't let me past this part

LinaJ2020
Expert Alumni

I did not work in a foreign country

 

If you are in the TurboTax desktop version, the steps would be different:

 

  • Open up your tax return if you have not already done so.
  • At the right upper corner, select Forms mode
  • In the Forms mode, the left side shows a list of all the generated forms, locate and click on the Form 2555 Foreign Earned Income or Form 1116 Foreign Tax Credit
  • At the bottom of that form, click Delete Form

@fredlorey

 

**Say "Thanks" by clicking the thumb icon in a post
**Mark the post that answers your question by clicking on "Mark as Best Answer"
LinaJ2020
Expert Alumni

I did not work in a foreign country

 

If you are in the TurboTax desktop version, the steps would be different:

 

  • Open up your tax return if you have not already done so.
  • At the right upper corner, select Forms mode
  • In the Forms mode, the left side shows a list of all the generated forms, locate and click on the Form 2555 Foreign Earned Income or Form 1116 Foreign Tax Credit
  • At the bottom of that form, click Delete Form

@fredlorey

**Say "Thanks" by clicking the thumb icon in a post
**Mark the post that answers your question by clicking on "Mark as Best Answer"
fredlorey
Level 1

I did not work in a foreign country

thank you so much!

fredlorey
Level 1

I did not work in a foreign country

Hi Lina - this is a different subject than the one you answered so  brilliantly ,  thank you , but thought you might be able to help.

in 2017 and 2018 I had $67,000 in losses of which I could only claim $25,000.  but it said the rest or some of it, could be carried over the following year.  but I see nowhere in tt 2019 premier to do that.  there is one section on loss carryover but it is a tiny piece of the whole, saying to go to form 3885A in 2018.  when I opened 2018 the first page said that form was one not available at the time I filed. so I updated 2018 and printed it out and found it.  but it was for one small segment of $1000 of which the line they referred to said I could carry over zero.    but the big losses were from my rental property and there seems to be no where to claim them. is this a tax change that you can no longer do it or am I missing some form?  I did the walk through but it didn't come up.  thanks so much if you can help.  my sister encountered the same problem.   Fred

KurtL1
Expert Alumni

I did not work in a foreign country

The passive losses on your rental property are reported on Form 8582. Looking on this form on your 2018 return you should see the losses carried over from 2017 and the losses carried forward to 2019.

 

**Say "Thanks" by clicking the thumb icon in a post
**Mark the post that answers your question by clicking on "Mark as Best Answer"
Privacy Settings
v