Sign Up

Why sign in to the Community?

  • Submit a question
  • Check your notifications
or and start working on your taxes
cancel
Showing results for 
Search instead for 
Did you mean: 
null280
New Member

Unable to complete Sch K-1 Wks-Partnership Sch E worksheet link for #7 Royalties It tells me to double-click to link royalties to Sch. E Worksheet, but fails to do so

 
1 Best answer

Accepted Solutions
MichaelDC
New Member

Unable to complete Sch K-1 Wks-Partnership Sch E worksheet link for #7 Royalties It tells me to double-click to link royalties to Sch. E Worksheet, but fails to do so

This is a common problem. Please feel free to respond in the comment section if this fix doesn't work.

Many times a fix has been to delete the offending K-1 and re-input. 

However, if you go back to the K-1 that is affected and click "edit".  Click through all the pages that you already entered until you get to the page "enter Box 13 info".  Make sure you didn't enter a "0" value for Code "I" related to "deductions-royalty income".  Better yet, delete the line and amount and enter again, if necessary.

or

If you delete just the Schedule K-1, it will regenerate if associated worksheets are still in the return.

The proper way to delete an unwanted K-1 is from the K-1 Summary screen, which also removes the associated worksheets.

1.       Open (continue) your return in TurboTax, if it's not already open.

2.       In your TurboTax program, search for K-1 or K1 (you can also use lower-case) and then click the "Jump to" link in the search results

3.       Answer Yes to Did you receive any Schedules K-1 or Q? (even if the correct answer is "no").

4.       Click Update next to the type of K-1 you initially entered (partnership/LLC, S corp, or estate/trust).

5.       On the K-1 Summary screen, click Delete next to the K-1 you want to remove. Answer Yes on the following screen.

6.       Click Done.

7.       If necessary, repeat Steps 4–7 for other K-1s you need to remove.


 

View solution in original post

9 Replies
MichaelDC
New Member

Unable to complete Sch K-1 Wks-Partnership Sch E worksheet link for #7 Royalties It tells me to double-click to link royalties to Sch. E Worksheet, but fails to do so

This is a common problem. Please feel free to respond in the comment section if this fix doesn't work.

Many times a fix has been to delete the offending K-1 and re-input. 

However, if you go back to the K-1 that is affected and click "edit".  Click through all the pages that you already entered until you get to the page "enter Box 13 info".  Make sure you didn't enter a "0" value for Code "I" related to "deductions-royalty income".  Better yet, delete the line and amount and enter again, if necessary.

or

If you delete just the Schedule K-1, it will regenerate if associated worksheets are still in the return.

The proper way to delete an unwanted K-1 is from the K-1 Summary screen, which also removes the associated worksheets.

1.       Open (continue) your return in TurboTax, if it's not already open.

2.       In your TurboTax program, search for K-1 or K1 (you can also use lower-case) and then click the "Jump to" link in the search results

3.       Answer Yes to Did you receive any Schedules K-1 or Q? (even if the correct answer is "no").

4.       Click Update next to the type of K-1 you initially entered (partnership/LLC, S corp, or estate/trust).

5.       On the K-1 Summary screen, click Delete next to the K-1 you want to remove. Answer Yes on the following screen.

6.       Click Done.

7.       If necessary, repeat Steps 4–7 for other K-1s you need to remove.


 

View solution in original post

rbmiller88
Returning Member

Unable to complete Sch K-1 Wks-Partnership Sch E worksheet link for #7 Royalties It tells me to double-click to link royalties to Sch. E Worksheet, but fails to do so

This worked.  Thanks a lot.  I went to box 13 and removed the entry for Code I, and that took care of it.
rbmiller88
Returning Member

Unable to complete Sch K-1 Wks-Partnership Sch E worksheet link for #7 Royalties It tells me to double-click to link royalties to Sch. E Worksheet, but fails to do so

BTW, if this is a known bug, why doesn't TurboTax just fix it by checking for '0' and ignoring it or prompting us about the condition?
stevenjsteinman
New Member

Unable to complete Sch K-1 Wks-Partnership Sch E worksheet link for #7 Royalties It tells me to double-click to link royalties to Sch. E Worksheet, but fails to do so

I'm still having this issue. It's on a different form but still the same "double click to select" does not work. Deleting and re-entering this form does not work.
sterlingcrispin
New Member

Unable to complete Sch K-1 Wks-Partnership Sch E worksheet link for #7 Royalties It tells me to double-click to link royalties to Sch. E Worksheet, but fails to do so

I ran into this same issue but the reported fix didn't work for me, in my situation I was reporting that I had different values in my K1 for a state return than a federal return and typed "0.0" into some of the boxes that should have been left blank. If you have this issue go back into the state return where you modified those values and delete the ones that were zero in both places
tniels22
Level 1

Unable to complete Sch K-1 Wks-Partnership Sch E worksheet link for #7 Royalties It tells me to double-click to link royalties to Sch. E Worksheet, but fails to do so

I followed the suggestion on this because I kept getting an error of having to manually calculate my QBI. I am really not technical with this kind of thing but the solution was to delete the K-1 Forms off federal return re-add them and then select the checkbox that my investment was 100% at risk. Although our business is small and there was no investment into it as it is service based. Hope this helps someone else.

San_Remo
New Member

Unable to complete Sch K-1 Wks-Partnership Sch E worksheet link for #7 Royalties It tells me to double-click to link royalties to Sch. E Worksheet, but fails to do so

The culprit on my return was $0 value on line 7. Eliminated that $0 and problem solved.

rearmstrong
New Member

Unable to complete Sch K-1 Wks-Partnership Sch E worksheet link for #7 Royalties It tells me to double-click to link royalties to Sch. E Worksheet, but fails to do so

Line 4 -Royalties received - will not let me enter "0" . keeps giving me an error.  Have re-enter the complete K-1 twice.  Please help.

KristinaK
Employee Tax Expert

Unable to complete Sch K-1 Wks-Partnership Sch E worksheet link for #7 Royalties It tells me to double-click to link royalties to Sch. E Worksheet, but fails to do so

Leave it blank. You do not need to enter zero. 

 

One thing to note is that if you have values in boxes 1 or 2 on the same K-1, you cannot enter that information in the same Schedule K-1 in TurboTax. You have to split it into 2 or even more K-1s. That's what is possibly giving you an error. 

 

@rearmstrong

Dynamic AdsDynamic Ads
Privacy Settings
v