Link to QBI Wksht must be entered
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Member

Link to QBI Wksht must be entered

There is a notification "Sch K-1 Wks Partnerships: Link to QBI Wksht must be entered," and Turbotax does not show any link or provide any other info to enter.  This is under Section D2, part "A".  It says "Does this K-1 include a Section 199A business?"  "Yes" is automatically selected (as it should be in my case).  Underneath that it says "QBI Worksheet to report (double-click to link)".   The problem is that double-clicking does absolutely nothing.  There's a free-text field, but no matter what I type into it, nothing works.  I'm stuck at this step.  I can't e-file because it says I have to "fix federal return" first, and when I click "fix federal return" it always brings me to this same page where I'm supposed to link to QBI Worksheet.  It's impossible to actually link it to a QBI Worksheet.  I assume this is a bug in TurboTax, and something is supposed to pop up when I double-click where it says to.  But nothing pops up.  Nothing happens at all.  As a result, I had to file an extension.  It will not let me e-file without fixing this "problem," and the problem is unfixable. 

PS - I have ad-block plus disabled on TurboTax, so it isn't that.  I'm also using Chrome, if that helps.

2 Replies
Highlighted
Expert Alumni

Link to QBI Wksht must be entered

Try to clear the "cache and cookies" from your browser, and then log into TurboTax Online again.  And, look for the box "hiding" behind another window on your computer screen.

 

What you should be seeing when you double click on that box is a pop-up that let's you select either an existing QBI Component worksheet in your tax return, or type in a name (e.g., of your business) to "Create a new copy".  Here's what that pop-up should look like:

 

**Say "Thanks" by clicking the thumb icon in a post
**Mark the post that answers your question by clicking on "Mark as Best Answer"
Highlighted
Expert Alumni

Link to QBI Wksht must be entered

For some reason the "QuickZoom" button that normally appears here, and the "double-click" feature are not functioning in TurboTax Online.

 

This situation has been reported to TurboTax for investigation.

 

Until this "QuickZoom" / "Double-Click" feature is working correctly again, do the following to "link" a QBI Component worksheet for your Schedule E:

 

Go back through the Schedule K-1 section in TurboTax.  Click through that section until you get to the QBI questions after your box 20 entry.  Find the screen "Should [name] be treated as part of a combined business" screen and make a selection here.  If you are not aggregating with other QBI businesses, select "This business is independent of any other activities".

 

@mlynch74d32204

**Say "Thanks" by clicking the thumb icon in a post
**Mark the post that answers your question by clicking on "Mark as Best Answer"
v
Privacy Settings