I am using Turbo Tax 2018 Home & Business - Entering assets is taking about 2 min each...VERY SLOW....Anyone else having the same issue?
Sign Up

Why sign in to the Community?

  • Submit a question
  • Check your notifications
or and start working on your taxes
Announcements
TurboTax has you covered during Covid. Get the latest second stimulus info here.
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

I am using Turbo Tax 2018 Home & Business - Entering assets is taking about 2 min each...VERY SLOW....Anyone else having the same issue?

I am using Turbo Tax 2018 Home & Business - Entering assets is taking about 2 min each...VERY SLOW....Anyone else having the same issue?

I am using a Surface Pro 3, which has a SSD and 16GB Ram - At 60% Hard drive space...I notice the APP is constantly running at over 40% CPU.  No way is it my machine.

 I tried disconnecting from the internet - No difference...updated - no difference...rebooted - no difference

I have used TurboTax for decades....never had an issue like this.  


Oh and for the record...it seems to be happening every other screen...

I am not sure why it needs to calculate until after the asset has been added...but that seems to be what it's waiting for.

3 Replies
Level 7

I am using Turbo Tax 2018 Home & Business - Entering assets is taking about 2 min each...VERY SLOW....Anyone else having the same issue?

It could be that several people are trying to do their taxes at the same time and the server is being overloaded.  The closer we get to April 17, the more potential for this exists.  Peak times are late afternoon and night.

New Member

I am using Turbo Tax 2018 Home & Business - Entering assets is taking about 2 min each...VERY SLOW....Anyone else having the same issue?

Is that for the locally installed application as well?  I disconnected from the internet to see if that was the case and it didn’t seem to have an issue.
New Member

I am using Turbo Tax 2018 Home & Business - Entering assets is taking about 2 min each...VERY SLOW....Anyone else having the same issue?

Funny - I searched here because I am having the same issue for TurboTax 2019!!!

 

I notice it hasn't been solved nor has my follow up question been responded to.

 

I am using H&B TurboTax 2019

Dynamic Ads
v
Privacy Settings