Sign Up

Why sign in to the Community?

  • Submit a question
  • Check your notifications
or and start working on your taxes
cancel
Showing results for 
Search instead for 
Did you mean: 
PaulDittmann
New Member

Can't Install new software on Mac. Says I need a higher operating system. Yet there are no updates available on my Mac. you have got to be KIDDING ME!!!

 
2 Replies
macuser_22
Level 15

Can't Install new software on Mac. Says I need a higher operating system. Yet there are no updates available on my Mac. you have got to be KIDDING ME!!!

The 2019 software is a new product that requires Mac OSX 10.13 or higher to run.  The Apple development tools (Supplied by Apple) and Apple has drooped support for software development for any OS before 10.13.

**Disclaimer: This post is for discussion purposes only and is NOT tax advice. The author takes no responsibility for the accuracy of any information in this post.**
BigChief
New Member

Can't Install new software on Mac. Says I need a higher operating system. Yet there are no updates available on my Mac. you have got to be KIDDING ME!!!

I agree.  This is FRAUD on the part of intuit - selling software that THEY KNOW won't work!!!

Dynamic AdsDynamic Ads
Privacy Settings
v