Solved: 200DB AMT depreciation method
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Member

200DB AMT depreciation method

Sch C Wks (Technician) -- Asset Entry Worksheet ( Tools, Stones): AMT depreciation method has an unacceptable value. Please cancel the override on this field to restore the calculated value.

I do not know what I am suppose to enter here? Will not let me proceed for california
1 Best answer

Accepted Solutions
Highlighted
Level 7

200DB AMT depreciation method

You have unfortunately encountered a known bug. The fix will be in the Feb 17 TT/Calif update. If you can override that field the correct method is 150DB. Overriding may prevent you from e-filing, though.

You can also fix it by editing that asset in the federal return and for the question, Elect out of Special Depreciation Allowance, check No. That will, however, change the computed depreciation deduction upwards on your federal return if the asset was placed in service in 2016, lowering your federal taxable income.

You can continue preparing other aspects of your return in the meantime.

View solution in original post

12 Replies
Highlighted
New Member

200DB AMT depreciation method

I too am running into this problem and it will not let me proceed for California.
Highlighted
New Member

200DB AMT depreciation method

I'm having the same problem
Highlighted
New Member

200DB AMT depreciation method

I'm having same issues and phone support had no resolution
Highlighted
New Member

200DB AMT depreciation method

Same problem with no fix
Highlighted
New Member

200DB AMT depreciation method

Same here...this is just silly
Highlighted
New Member

200DB AMT depreciation method

I was finally able to find a workaround that worked for e-file. I deleted all my assets that were having this issue and returned to the review to make sure they were gone. I then re-entered them in the business section. I had to do this multiple times however, because sometimes I would still get the same error on a couple of assets. So I would go back and just re-enter the assists that were having issues. Eventually they all worked after the 3rd or 4th try. (My last asset wasn't working and I finally got it to work by not clicking bought it new and just left that question blank.)
Highlighted
New Member

200DB AMT depreciation method

Same problem here. Can't get out of the endless error check loop.
Highlighted
New Member

200DB AMT depreciation method

Same problem. Please help
Highlighted
Level 7

200DB AMT depreciation method

You have unfortunately encountered a known bug. The fix will be in the Feb 17 TT/Calif update. If you can override that field the correct method is 150DB. Overriding may prevent you from e-filing, though.

You can also fix it by editing that asset in the federal return and for the question, Elect out of Special Depreciation Allowance, check No. That will, however, change the computed depreciation deduction upwards on your federal return if the asset was placed in service in 2016, lowering your federal taxable income.

You can continue preparing other aspects of your return in the meantime.

View solution in original post

Highlighted
New Member

200DB AMT depreciation method

Super disappointed with this... if it's a known issue, it should be fixed immediately. I have been ready to file my taxes for weeks but TurboTax has been my hold-up this year. First for home office stuff and now for this. Come on TurboTax! I shouldn't be waiting on you!
Highlighted
New Member

200DB AMT depreciation method

I'm pretty annoyed about this also. This caused me to restart my entire return to try and fix it which was a total waste of time (3 hours or so).
Highlighted
New Member

200DB AMT depreciation method

It's now April 6, 2016, I'm up to date and I still can't enter 150DB as the depreciation method.
v
Privacy Settings