Solved: Entered montage interest however when overview it ...
Sign Up

Why sign in to the Community?

  • Submit a question
  • Check your notifications
or and start working on your taxes
cancel
Showing results for 
Search instead for 
Did you mean: 
jzheng2011
Level 2

Entered montage interest however when overview it is 0, and it recommends to use standard deduction because of this. Last year it is different.

I entered my mortgage interest the same way as last year. Last year it recommends to use itemized deductions. this year's situation is similar, however it recommends using standard deductions. The reason is simply because mortgage interest is considered 0 at the summary page.

I am using turbotax premier.

 

1 Best answer

Accepted Solutions
JotikaT2
Employee Tax Expert

Entered montage interest however when overview it is 0, and it recommends to use standard deduction because of this. Last year it is different.

The problem may occur if you have refinanced during the year, and the input reads your data as exceeding the $750,000 limit to be deductible.

 

If you are working in the Desktop version, you can try the following as provided by jmcglass.  

  • Click on the View link on the top menu bar
  • Click on Forms
  • Locate and click on 'Tax & Int Wks' on the left-hand side of the screen (under Forms in My Return)
  • On the form, scroll down to the 'Mortgage Interest Limited Smart Worksheet'
  • Click on the 'No' box, to the right of the question 'Does your mortgage interest need to be limited.' 

If you are working in the online version, please go back to deductions and credits and mortgage interest.

Click through until you get to a screen that says "Do any of these situations apply to you?  Mark yes on the next screen, take out the zero, click back and choose "No".

**Say "Thanks" by clicking the thumb icon in a post
**Mark the post that answers your question by clicking on "Mark as Best Answer"

View solution in original post

4 Replies
jzheng2011
Level 2

Entered montage interest however when overview it is 0, and it recommends to use standard deduction because of this. Last year it is different.

Last year, the deductions are like: 10,000(for state income tax and real estate tax) + mortgage interest

This year, it is only the first part. I double checked the mortgage interest part, it did say, I get the deduction. But in the summary page, it shows 0, and the total itemized deduction is on 10,000

JosephF8
Expert Alumni

Entered montage interest however when overview it is 0, and it recommends to use standard deduction because of this. Last year it is different.

Please go back in to edit the 1098. Pay special attention to boxes 7 and 8. Also check the outstanding mortgage balance.

**Say "Thanks" by clicking the thumb icon in a post
**Mark the post that answers your question by clicking on "Mark as Best Answer"
jzheng2011
Level 2

Entered montage interest however when overview it is 0, and it recommends to use standard deduction because of this. Last year it is different.

Box 7 is checked, and it did say: [And I tried it quite a few times checked or unchecked]

"

Congratulations, you get a tax break.

you are getting a deduction of xxxxx for the mortgage interest you paid.

"

But after I clicked "Done with deductions", after it did the analyzing, it went to the summary of my 2018 and 2019 deductions & credits. 2018 is there because I imported it. It is clearly comparison. Itemized deduction is 0 for "Mortgage Interests". 

 

Two differences :

1) last year I used windows version, this year it is Mac version.

2) this year because of refinance (a very regular refinance, no cash out), there are two extra 1098. Just one refinance, but the bank quickly sold it to another one. All have box 7 Checked. 

 

Is there any software bug here. I also saw other people complaining the same.

 

 

JotikaT2
Employee Tax Expert

Entered montage interest however when overview it is 0, and it recommends to use standard deduction because of this. Last year it is different.

The problem may occur if you have refinanced during the year, and the input reads your data as exceeding the $750,000 limit to be deductible.

 

If you are working in the Desktop version, you can try the following as provided by jmcglass.  

  • Click on the View link on the top menu bar
  • Click on Forms
  • Locate and click on 'Tax & Int Wks' on the left-hand side of the screen (under Forms in My Return)
  • On the form, scroll down to the 'Mortgage Interest Limited Smart Worksheet'
  • Click on the 'No' box, to the right of the question 'Does your mortgage interest need to be limited.' 

If you are working in the online version, please go back to deductions and credits and mortgage interest.

Click through until you get to a screen that says "Do any of these situations apply to you?  Mark yes on the next screen, take out the zero, click back and choose "No".

**Say "Thanks" by clicking the thumb icon in a post
**Mark the post that answers your question by clicking on "Mark as Best Answer"

View solution in original post

Dynamic AdsDynamic Ads
v
Privacy Settings