Solved: In the Review Form List I click to delete the forms related to Qualified Business Income. It says they are deleted, but they still appear in the list. Why?
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Level 1

In the Review Form List I click to delete the forms related to Qualified Business Income. It says they are deleted, but they still appear in the list. Why?

Also, I wouldn't expect to have Qualified Business Income since I don't have any partnership, LLC, S-Corp. I do have some investments including assets that produce foreign income -- should they produce the QBI-related forms?
1 Best answer

Accepted Solutions
Highlighted
Level 4

In the Review Form List I click to delete the forms related to Qualified Business Income. It says they are deleted, but they still appear in the list. Why?

If you have any 1099-DIV, that could trigger it. 

"The deduction is generally equal to the lesser of 20% of the taxpayer’s QBI plus 20% of the taxpayer’s qualified REIT dividends and qualified PTP income, or 20% of taxable income minus net capital gains. Deductions for taxpayers with taxable incomes above certain threshold amounts (which are adjusted annually for inflation) may be limited."

https://www.journalofaccountancy.com/news/2019/feb/sec-199a-qbi-deduction-form-201920659.html

View solution in original post

1 Reply
Highlighted
Level 4

In the Review Form List I click to delete the forms related to Qualified Business Income. It says they are deleted, but they still appear in the list. Why?

If you have any 1099-DIV, that could trigger it. 

"The deduction is generally equal to the lesser of 20% of the taxpayer’s QBI plus 20% of the taxpayer’s qualified REIT dividends and qualified PTP income, or 20% of taxable income minus net capital gains. Deductions for taxpayers with taxable incomes above certain threshold amounts (which are adjusted annually for inflation) may be limited."

https://www.journalofaccountancy.com/news/2019/feb/sec-199a-qbi-deduction-form-201920659.html

View solution in original post

Privacy Settings