Sign Up

Why sign in to the Community?

  • Submit a question
  • Check your notifications
or and start working on your taxes
cancel
Showing results for 
Search instead for 
Did you mean: 
artythe1
New Member

I just purchased TT 2016 deluxe but when i install cd on my mac it says my ios needs to be 10.9 or higher. I am unable to see any updates

 
1 Best answer

Accepted Solutions
CathyD
New Member

I just purchased TT 2016 deluxe but when i install cd on my mac it says my ios needs to be 10.9 or higher. I am unable to see any updates

I regret that you can not open the CD that you purchased on your Mac.  I am including the contact information for TurboTax customer service.  The agent will be able to push a download to you.  There will be no charge for the download since you have paid already for the CD.  

If you're using the TurboTax CD/Download software or can't sign into your account, click here to contact us. Ask your question, click Continue, and follow our onscreen instructions

View solution in original post

3 Replies
CathyD
New Member

I just purchased TT 2016 deluxe but when i install cd on my mac it says my ios needs to be 10.9 or higher. I am unable to see any updates

I regret that you can not open the CD that you purchased on your Mac.  I am including the contact information for TurboTax customer service.  The agent will be able to push a download to you.  There will be no charge for the download since you have paid already for the CD.  

If you're using the TurboTax CD/Download software or can't sign into your account, click here to contact us. Ask your question, click Continue, and follow our onscreen instructions

Opus 17
Level 15

I just purchased TT 2016 deluxe but when i install cd on my mac it says my ios needs to be 10.9 or higher. I am unable to see any updates

The mac download has the same operating system requirements as the CD (they are both Turbotax Desktop for Mac).  The customer needs to upgrade their Mac operating system or switch to the online or PC version.
*Answers are correct to the best of my ability at the time of posting but do not constitute legal or tax advice.*
Opus 17
Level 15

I just purchased TT 2016 deluxe but when i install cd on my mac it says my ios needs to be 10.9 or higher. I am unable to see any updates

The upgrade from Mac OS 10.7.5 (Lion) to 10.8.6 (Mountain Lion) was a paid upgrade, so it won't show as something you can download. All the upgrades after Mountain Lion have been free, but not all Mac systems can be fully upgraded.   There are free ways to upgrade from Lion to something higher, but it can be a bit tricky and the ultimate version that can be installed depends on your hardware.

Helping you upgrade your mac system is not really a function of this board.  If you can upgrade your Mac, you will be able to install from the CD.  The download version has the same requirements and can't be installed unless you upgrade your Mac.  

If you don't want to, or can't upgrade, or can't upgrade in time, you will either have to borrow another Mac, borrow a PC to install Turbotax on, or switch to using  the web browser version.  Since you already paid for the CD version and the web browser version is payable online when you file, you can either return the CD where you bought it, or contact customer support about a refund, or use the Satisfaction Guarantee to get a refund for the CD.


The Satisfaction Guaranteed policy and claim form are here.

https://ttlc.intuit.com/replies/3301962


Customer support can be reached via Twitter, Facebook or telephone. https://www.facebook.com/turbotax/ and https://twitter.com/TeamTurboTax.  

For telephone and other support options, see the instructions below. 

https://ttlc.intuit.com/replies/3300041


*Answers are correct to the best of my ability at the time of posting but do not constitute legal or tax advice.*
Dynamic AdsDynamic Ads
Privacy Settings
v