TurboTax FAQ
TurboTax FAQ
36 people found this useful

What if I don't want to upgrade Mac OS X 10.9 or 10.10?

Although you can install and use TurboTax 2016 on Mac OS X 10.9.5 (Mavericks) and Mac OS X 10.10.5 (Yosemite), you won't be able to install TurboTax 2017 or beyond.

Assuming you haven't upgraded or changed computers by then, you might consider TurboTax Online for your future tax-prep needs, as it has lower system requirements and doesn't require a software installation.


GEN88067