TurboTax FAQ
TurboTax FAQ
1236 people found this useful

What if I don't want to upgrade from Windows Vista?

Because TurboTax 2017 for Windows requires Windows version 7 or later, consider TurboTax Online for your 2017 tax-prep needs (available in late November).

TurboTax 2016 will run on Vista as well as later Windows releases.


GEN88065