Why sign in to the Community?

  • Submit a question
  • Check your notifications
or and start working on your taxes
English EN

Pick a language

Canada English Canada Français
cancel
Showing results for 
Search instead for 
Did you mean: 
TurboTax Help
Intuit

What if I don't want to upgrade my Mac?

TurboTax 2018 for Mac requires OS X v10.12 (Sierra), so if you don't want to upgrade to High Sierra (or later) you can use TurboTax Online for your 2019 tax-prep needs.

Next year, TurboTax for Mac will require 10.13 (High Sierra), so if you've been thinking about upgrading your system, now might be a good time to do it.

Was this helpful?

You must sign in to vote, reply, or post
Dynamic AdsDynamic Ads
Privacy Settings
v