Solved: We've paid 2017 estimated taxes and it doesn't show up? I show federal tax due and paid more than that in estimated taxes. I'm using Turbo Tax Deluxe.
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Member

We've paid 2017 estimated taxes and it doesn't show up? I show federal tax due and paid more than that in estimated taxes. I'm using Turbo Tax Deluxe.

 
1 Best answer

Accepted Solutions
Highlighted
Level 6

We've paid 2017 estimated taxes and it doesn't show up? I show federal tax due and paid more than that in estimated taxes. I'm using Turbo Tax Deluxe.

You have to enter your estimated taxes paid in TurboTax.

You enter the estimated taxes you paid by following these steps:

  • In TurboTax, open your tax return
  • Click on Federal in the left-hand column, then Deductions & Credits on top of the screen
  • Scroll down to All tax breaks, locate the section named Estimates and Other Taxes Paid and click Show more
  • Click on Start next to Estimated Taxes
  • On the next page, click Start next to Federal estimated taxes for 2017 (form 1040ES)

 


**Say "Thanks" by clicking the thumb icon in a post
**Mark the post that answers your question by clicking on "Mark as Best Answer"

View solution in original post

1 Reply
Highlighted
Level 6

We've paid 2017 estimated taxes and it doesn't show up? I show federal tax due and paid more than that in estimated taxes. I'm using Turbo Tax Deluxe.

You have to enter your estimated taxes paid in TurboTax.

You enter the estimated taxes you paid by following these steps:

  • In TurboTax, open your tax return
  • Click on Federal in the left-hand column, then Deductions & Credits on top of the screen
  • Scroll down to All tax breaks, locate the section named Estimates and Other Taxes Paid and click Show more
  • Click on Start next to Estimated Taxes
  • On the next page, click Start next to Federal estimated taxes for 2017 (form 1040ES)

 


**Say "Thanks" by clicking the thumb icon in a post
**Mark the post that answers your question by clicking on "Mark as Best Answer"

View solution in original post

v
Privacy Settings