cancel
Showing results for 
Search instead for 
Did you mean: 
Level 2

Stupid Security

I am trying to import tax documents from various companies.  Of course, Turbo Tax is asking for my user id and password.  When you want to put in the password you are not allowed to paste it via the context menu but you are also not allowed to to use the keyboard to paste the password.

 

This is security reaching stupidity.  In today's world we must have passwords that are complicated and long.  To have to type in every password is ridiculous.  Intuit you need to fix this.  It is annoying and has not benefit.  If you think that a hacker wouldn't be able to find the password via the clipboard by it not being there, you're wrong.  Most of us put the password in the clipboard without thinking about it.  You are just making the whole process more of a pain than it already is without good reason.  Also, you are not consistent with this.  In some fields I can paste the password via the keyboard.

 

Please fix this, as it is annoying, and there isn't a good reason for it.  If a hacker were on your system you'd have a lot more to worry about than a password.

2 Replies
Highlighted
Level 2

Stupid Security

Not allowing copy/paste of financial passwords defeats a very useful feature of TurboTax. I don't know how you think this makes your product more secure or saves users from themselves or whatever. I have very secure passwords for important financial sites. Can't just type away and enter them, but you are obviously not idiots - you know that is true for most users.

 

You somehow you think this is an important feature since it's been there. How about giving users the option to paste user credentials after warning them of whatever danger you think you are protecting us from?

 

HOW ABOUT AT LEAST ADDRESSING THIS IN YOUR FAQs?!!!!

Level 2

Stupid Security

There is a workaround I found! It takes a little computer savvy but works. You can find the instructions here:

https://groups.google.com/forum/#!topic/alt.comp.software.financial.quicken/j_CDiXE7JLk

Now if TT is listening, they should undo this stupid policy. I have upgraded all my finance passwords to long gibberish to make them most secure. They are impossible to type. It would be easier to enter the numbers.

Summarizing:

A relatively simple work around is to use a program such as AutoHotKey to "paste" from the clipboard: https://autohotkey.com 

Improved  AutoHotKey script on Windows: 

^!v:: ; a paste replacement 
  tclipboard := RegExReplace(clipboard, "\r\n$") 
  SendInput {Raw}%tclipboard% 
return