Sign Up

Why sign in to the Community?

  • Submit a question
  • Check your notifications
or and start working on your taxes
cancel
Showing results for 
Search instead for 
Did you mean: 
nvshah9
Level 1

Why does foreign tax paid reported, later shows up as "Generation-skipping tax" in Turbotax ?

 
1 Best answer

Accepted Solutions
rjs
Level 15
Level 15

Why does foreign tax paid reported, later shows up as "Generation-skipping tax" in Turbotax ?

TurboTax asked you whether you whether you want to take an itemized deduction or a credit for the foreign tax. Your original question said that the foreign tax showed up later in the interview under generation-skipping tax. That's the itemized deduction. The itemized deduction for foreign tax paid does not use Form 1116. The deduction appears on Schedule A line 6.


If you choose the foreign tax credit, Form 1116 is used to calculate the credit. The credit from Form 1116 line 33 flows to Schedule 3 line 1.


It's not clear what you did when you entered the foreign tax multiple times, or why it seemed to keep disappearing. You might have been switching back and forth between the itemized deduction and the credit without realizing it.


The best suggestion I can give you regarding TurboTax is to go through the questions slowly, read every word on every screen very carefully, and make use of the help links. Make sure all your answers are accurate. The itemized deduction is fairly simple, but the credit requires a lot of information for Form 1116 and can be very confusing. That's because the tax rules are complex and confusing.


You might want to call TurboTax support for help, or consult a local tax professional, but you are not likely to be able to reach either of those on the day of the filing deadline, which is tomorrow (Wednesday, July 15). Perhaps you should file an extension so that you can take more time to work out the foreign tax problems.

 


@nvshah9 wrote:

I don't know why.  On form 1116, it shows final number as 0 that should be reported on 1040 line 46.


There is no line 46 on Form 1040. Form 1116 does not say that the credit goes on Form 1040 line 46. It says it goes on Schedule 3 line 1 or Form 1040-NR line 46. Form 1040-NR is not the same as Form 1040, and it is not supported in TurboTax. You are not filing Form 1040-NR.

 

View solution in original post

5 Replies
rjs
Level 15
Level 15

Why does foreign tax paid reported, later shows up as "Generation-skipping tax" in Turbotax ?

That's just a weird quirk in the design of the TurboTax interview. The foreign tax will go to the correct place on the forms. It will be shown on Schedule A line 6 with the description that you entered. You will see it there when you print your tax return or review it before you file. Generation skipping tax goes on the same line. That's why TurboTax handles it this way.

 

nvshah9
Level 1

Why does foreign tax paid reported, later shows up as "Generation-skipping tax" in Turbotax ?

Another weird issue I found was, TT kept on deleting the prior foreign tax entries and I had to go do it again.  It's very confusing.  I felt like why didn't I hire a CPA instead of relying on TT.  Thank you for your prompt reply.

nvshah9
Level 1

Why does foreign tax paid reported, later shows up as "Generation-skipping tax" in Turbotax ?

@rjs , I just downloaded the final tax return PDF before I file and I see that foreign tax credit hasn't been even applied.  I don't know why.  On form 1116, it shows final number as 0 that should be reported on 1040 line 46.  The entire foreign tax credit interview was VERY confusing so I don't know what I have done wrong.  :(

rjs
Level 15
Level 15

Why does foreign tax paid reported, later shows up as "Generation-skipping tax" in Turbotax ?

TurboTax asked you whether you whether you want to take an itemized deduction or a credit for the foreign tax. Your original question said that the foreign tax showed up later in the interview under generation-skipping tax. That's the itemized deduction. The itemized deduction for foreign tax paid does not use Form 1116. The deduction appears on Schedule A line 6.


If you choose the foreign tax credit, Form 1116 is used to calculate the credit. The credit from Form 1116 line 33 flows to Schedule 3 line 1.


It's not clear what you did when you entered the foreign tax multiple times, or why it seemed to keep disappearing. You might have been switching back and forth between the itemized deduction and the credit without realizing it.


The best suggestion I can give you regarding TurboTax is to go through the questions slowly, read every word on every screen very carefully, and make use of the help links. Make sure all your answers are accurate. The itemized deduction is fairly simple, but the credit requires a lot of information for Form 1116 and can be very confusing. That's because the tax rules are complex and confusing.


You might want to call TurboTax support for help, or consult a local tax professional, but you are not likely to be able to reach either of those on the day of the filing deadline, which is tomorrow (Wednesday, July 15). Perhaps you should file an extension so that you can take more time to work out the foreign tax problems.

 


@nvshah9 wrote:

I don't know why.  On form 1116, it shows final number as 0 that should be reported on 1040 line 46.


There is no line 46 on Form 1040. Form 1116 does not say that the credit goes on Form 1040 line 46. It says it goes on Schedule 3 line 1 or Form 1040-NR line 46. Form 1040-NR is not the same as Form 1040, and it is not supported in TurboTax. You are not filing Form 1040-NR.

 

View solution in original post

nvshah9
Level 1

Why does foreign tax paid reported, later shows up as "Generation-skipping tax" in Turbotax ?

@rjs 

It worked. I wasn't entering gross income when it was asking for it.  Because it had the instructions regarding INT-1099/DIV and I was getting confused that because I had already reported it, I didn't have to report here again.  That was the missing part.  Thank you so much for your reply in detail.

Dynamic AdsDynamic Ads
Privacy Settings
v