Solved: A significant shortcoming of TT is that if you hav...
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Level 1

Hello! I am attempting to determine my foreign tax credit. However, the prompts are only allowing me to enter one country source per brokerage. Is this a known bug?

 
1 Best answer

Accepted Solutions
Highlighted
Level 8

Hello! I am attempting to determine my foreign tax credit. However, the prompts are only allowing me to enter one country source per brokerage. Is this a known bug?

A significant shortcoming of TT is that if you have to fill out Form 1116, it can support only one country per Payer.  In the past, if there were more countries than Payers, using “Various” was the technique used to restore the 1 to 1 country/payer ratio. The following technique restores this 1 to 1 ratio by creating additional payers to equal the number of countries.

This addresses the issue of a 1099-DIV with Box 7 showing foreign tax paid to multiple foreign countries and it is necessary to identify and list the countries individually on Form 1116. This is done by utilizing Dummy 1099-DIV's as illustrated by the following example.

We have a 1099-DIV with Box 7 displaying the total tax paid to 3 foreign countries we will call “A”, “B”, and “C”.

Navigate to the “Here’s the dividend info we have so far” screen displaying the name of the Payer. This will be our Main Screen.  Bring the Payer up in EDIT mode.  Change Box 7 to the amount paid to  “A”.  Click “Continue “.  Either the Main Screen will appear or 2 consecutive screens asking for dividends paid and the source country.  If the latter occurs, insert the data for  “A”, then continue to the Main Screen.

Click on the New Payer button.  We will name this Payer “Dummy1”.  In Box 1a, put a zero.  This prevents TT from issuing an error. In Box 7, enter the tax paid to “B”.  Leave the remaining boxes blank. Click “Continue” back to the Main Screen.

Again open up a New Payer.  We will name this “Dummy2”.  Put a zero In Box 1a and in Box 7 the tax paid to “C”.  Click  “Continue” back to the Main Screen.

Now when we go to the Foreign Tax Credit Interview Section, we are positioned to enter all the necessary data for each country individually.

Now we consider countries “D”, “E”, “F” etc.  
When multiple copies of form 1116 are needed, they have to be created in the right order.
Using TT’s special instructions as a guideline, the following strategy is suggested. Assign to “A” the largest tax paid, then to “B” the 2nd largest and so on through to “F”.  Then when we enter the Foreign Tax Credit Interview Section, we run them through in the same order; greatest to the least.

You may find on part 2 of Form 1116, it is necessary to type in the date for the fictitious Payers which will be the same as the actual Payer, usually 12/31/2018..
Due to recent changes, false errors may appear on the f1116 wks. in part 1, lines 1h, 1i, and 1j. Override them with zeroes to clear the error.


View solution in original post

3 Replies
Highlighted
Level 8

Hello! I am attempting to determine my foreign tax credit. However, the prompts are only allowing me to enter one country source per brokerage. Is this a known bug?

A significant shortcoming of TT is that if you have to fill out Form 1116, it can support only one country per Payer.  In the past, if there were more countries than Payers, using “Various” was the technique used to restore the 1 to 1 country/payer ratio. The following technique restores this 1 to 1 ratio by creating additional payers to equal the number of countries.

This addresses the issue of a 1099-DIV with Box 7 showing foreign tax paid to multiple foreign countries and it is necessary to identify and list the countries individually on Form 1116. This is done by utilizing Dummy 1099-DIV's as illustrated by the following example.

We have a 1099-DIV with Box 7 displaying the total tax paid to 3 foreign countries we will call “A”, “B”, and “C”.

Navigate to the “Here’s the dividend info we have so far” screen displaying the name of the Payer. This will be our Main Screen.  Bring the Payer up in EDIT mode.  Change Box 7 to the amount paid to  “A”.  Click “Continue “.  Either the Main Screen will appear or 2 consecutive screens asking for dividends paid and the source country.  If the latter occurs, insert the data for  “A”, then continue to the Main Screen.

Click on the New Payer button.  We will name this Payer “Dummy1”.  In Box 1a, put a zero.  This prevents TT from issuing an error. In Box 7, enter the tax paid to “B”.  Leave the remaining boxes blank. Click “Continue” back to the Main Screen.

Again open up a New Payer.  We will name this “Dummy2”.  Put a zero In Box 1a and in Box 7 the tax paid to “C”.  Click  “Continue” back to the Main Screen.

Now when we go to the Foreign Tax Credit Interview Section, we are positioned to enter all the necessary data for each country individually.

Now we consider countries “D”, “E”, “F” etc.  
When multiple copies of form 1116 are needed, they have to be created in the right order.
Using TT’s special instructions as a guideline, the following strategy is suggested. Assign to “A” the largest tax paid, then to “B” the 2nd largest and so on through to “F”.  Then when we enter the Foreign Tax Credit Interview Section, we run them through in the same order; greatest to the least.

You may find on part 2 of Form 1116, it is necessary to type in the date for the fictitious Payers which will be the same as the actual Payer, usually 12/31/2018..
Due to recent changes, false errors may appear on the f1116 wks. in part 1, lines 1h, 1i, and 1j. Override them with zeroes to clear the error.


View solution in original post

Highlighted
Level 1

Hello! I am attempting to determine my foreign tax credit. However, the prompts are only allowing me to enter one country source per brokerage. Is this a known bug?

This seems terribly complicated over just entering "various." Why did you change? I was guessing that "various" went away or something, but it is a choice for country.

Highlighted
Level 15

Hello! I am attempting to determine my foreign tax credit. However, the prompts are only allowing me to enter one country source per brokerage. Is this a known bug?

not really a bug since even pro software does it the same way. if you have multiple countries use "various"

v
Privacy Settings