I answered the questions from which Form 8606 shou...
Sign Up

Why sign in to the Community?

  • Submit a question
  • Check your notifications
or and start working on your taxes
cancel
Showing results for 
Search instead for 
Did you mean: 
wkeene
New Member

I answered the questions from which Form 8606 should be completed. Turbo Tax ignores it and reports all of my RMD as taxable. How do I fix this.

 
4 Replies
DawnC
Employee Tax Expert

I answered the questions from which Form 8606 should be completed. Turbo Tax ignores it and reports all of my RMD as taxable. How do I fix this.

We'll automatically generate and fill out Form 8606 (Nondeductible IRAs) if you reported any of these on your tax return:

  • Nondeductible contributions made to a traditional IRA
  • Distributions from a traditional, SEP or SIMPLE IRA that had nondeductible contributions (excluding rollovers, conversions, recharacterizations, qualified charitable distributions, one-time distribution to fund an HSA, or return of certain contributions)
  • Conversions from a traditional, SEP, or SIMPLE IRA to a Roth IRA
  • Distributions from a Roth IRA (other than rollovers, recharacterizations, or a return of certain contributions)

However, if any of these 3 situations apply to you:

  1. You received a distribution from an inherited traditional IRA that had nondeductible contributions
  2. You transferred an inherited plan account to a Roth IRA
  3. You received a distribution from an inherited Roth IRA that was not a qualified distribution

then you'll have to download and print Form 8606, manually fill it out (instructions), and print and file your return, as you won't be able to e-file.  

 

To trigger the 8606 in TurboTax

For the 4 situations listed at the top of this article, you can trigger Form 8606 with these instructions:

 

  1. Open your return if it isn't already open.
  2. Inside TurboTax, search for this exact phrase, including the comma: 8606, nondeductible ira contributions
  3. Select the Jump to link in the search results.
  4. Proceed through the IRA section, answering questions as you go.
  5. When you reach the screen Any nondeductible contributions to [taxpayer's] IRA? answer Yes, then continue. We'll generate and fill out the 8606 behind the scenes.

Tip: On joint returns, 8606-T stands for "taxpayer" (first person listed on the return) and 8606-S denotes "spouse."

Related Information:

**Say "Thanks" by clicking the thumb icon in a post
**Mark the post that answers your question by clicking on "Mark as Best Answer"
Jimaball9
New Member

I answered the questions from which Form 8606 should be completed. Turbo Tax ignores it and reports all of my RMD as taxable. How do I fix this.

Exact same issue with 8606 ignoring distributions despite filling out (and deleting and refilling) a 1099-R in TT Deluxe for 2019.  Succesfully completed this exact action using TT Deluxe 2018 and have also correctly calculated the 8606 line 13 values following instructions in IRS publication 590-B.

sctrim
New Member

I answered the questions from which Form 8606 should be completed. Turbo Tax ignores it and reports all of my RMD as taxable. How do I fix this.

The questions asked in Turbo tax regarding a Traditional IRA contribution and then a recharacterization to a Roth IRA(Back-door), do NOT produce a correctly completed 8606! As a high income earner, the response is continually "your income is to high" which in turn produces another Tax event. I've tried answering every one of the questions differently and the program still does not correctly complete a 8606.

fanfare
Level 15

I answered the questions from which Form 8606 should be completed. Turbo Tax ignores it and reports all of my RMD as taxable. How do I fix this.

A) you must make the non-deductible election on an IRA contribution before the backdoor Roth conversion can work.

There is no income limit for a non-deductible contribution.

 

B) It is a conversion, not a recharacterization,

if you are responding with recharacterization, it will not work.

Dynamic AdsDynamic Ads
v
Privacy Settings