clark7945
New Member

LTC premiums not showing up on my WI tax form

I have entered my LTC premium on my Federal form Schedule A but it did not forward to the state WI form.  Now what do I do?

DaveF1006
Employee Tax Expert

State tax filing

Go through your Wisconsin State return. As you answer questions, you will come to a screen that says Here's the income that Wisconsin handles differently. Below is a category that says, medical>medical care insurance. Enter your LTC premium as: 

 

Employee or Unemployed:

 

Amount paid for medical care insurance while (1) you were an employee and your employer did not contribute toward the cost of your insurance, or (2) you had no employer and were not self-employed. Enter the premium in the space provided.

**Say "Thanks" by clicking the thumb icon in a post
**Mark the post that answers your question by clicking on "Mark as Best Answer"
632powermom
New Member

State tax filing

I am able to enter my medical insurance premiums in addition to my LTC premiums as I am retired (my medical insurance premiums are not thru the marketplace).  The Wisconsin Form 1 has different codes to identify medical vs LTC premiums.  There is no way to enter these premiums correctly using TurboTax.  Entering LTC premiums have been an issue with TurboTax for years on the WI state form and needs to be corrected (I did not have an issue when I was employed to do this work around).  I do not feel comfortable combining them on the TurboTax form.  Wonder if the competitors have it correct on their forms?  I guess I will file my state directly on the WI state website for free so I know it will be correct.

GTPS
Returning Member

State tax filing

Actually, this has to be entered on the Federal side.  😁

Under medical expenses. Deductions and credits > medical. So even if you don't have "enough" medical to itemize, you say yes anyway. I tested it and entering on the Federal side under medical expenses (you have to walk through a lot of screens to get there) does carry to the correct WI worksheet.

Privacy Settings