Re: The turbotax app is rejecting the canadian zip...
Level 13

Get your taxes done using TurboTax

Try the following:


1. If you have a copy of your Canadian W-2, please delete the W-2 that you entered. To delete it, do a Search for w-2 and click on the jump-to result. Mac users need to find w-2 in the Topics List.

2. You should see a table of W-2s (maybe only the one). Delete it by clicking on the Delete button or the trash can icon.

3. Click on the Add a W-2 button.

4. Continue past the screen that asks for the employer EIN.

5. On the next screen that has all the fields which ask for the boxes on the W-2, before you do anything else, look for the choice of Foreign address. Note that this is done differently in different versions of the product, because you should see either a box with a pull-down arrow that is preloaded with the phrase "U.S. Address" which you need to change to foreign address, or click on a box that specifies foreign address, which changes the layout of the other boxes.

6. Once you do this, you will be able to enter your Canadian address, including the postal code.

View solution in original post

This widget could not be displayed.
Privacy Settings